Certified Devices for BlackBerry/Good Secure Apps

BlackBerry/Good supports all devices based on OS level. The certified device listing is a list of devices we have been able to test and verify functionality of the BlackBerry/Good software products. Certified devices undergo comprehensive testing to ensure the security and functionality of the BlackBerry/Good solutions on them. 

Please note that all devices (other than those on our unsupported list) are supported, whether certified or not, assuming they meet the minimum hardware and OS specifications.

  • 1 GB or more of RAM
  • 8 GB or more of internal storage
  • iOS 7.0 or greater for GFE
  • iOS 9.0 or greater for BlackBerry Dynamics apps
  • Android 4.4 or greater

 

If you have a device that is on the certified list and you are having issues, please look at the linked page to check if the devices system software has been tested. Please note the list is only a years worth of certifications so if its an older device we will have to look through our records. Certified device system version info.