42 Replies Latest reply: Jan 14, 2016 7:40 PM by BlackBerry Technical Support RSS

Unable to Download Attachments

grahamp Newbie

Evening all,


I have a user who is suddenly not able to download any attachments on their iPad 2. He just receives an interminable
"connecting" message
. The same user also has an iPhone and this is fine.


Anyone else experience this issue? Any advice gratefully accepted.


GFE for Exchange.


Best Regards,



  • Re: Unable to Download Attachments

    Check device available space-also clear device cache

  • Re: Unable to Download Attachments
    frank Newbie



    I got also a user who travelled to USA and he receives mails but he can´t download attachments.

    He just see the message "connecting".

    Was the hint of Al Bechara successful?




  • Re: Unable to Download Attachments
    aoc1230 Newbie

    I'm also having issues with Androids as of this week where they intermintently cannot open word documents.

  • Re: Unable to Download Attachments
    ndjake Newbie

    I've seen this issue a few times.  I always end up re-provisioning it, but it would be great if someone could find an easier fix.

    • Re: Unable to Download Attachments
      saenz Novice

      I had this issue before and we ended up resolving after doing some extensive cleanup on our datacenter LAN. Mainly, we removed a bunch of old rules that were still getting high hit counts from our firewall and found out our router was set to 100MB half duplex when our switch was set to 1000MB full. Got that worked out and have not had an attachment hang up since. Just saying might not specifically be your GMM server, could be something unrelated. Hope that helps.



  • Re: Unable to Download Attachments

    After playing around with it a bit, my co-workers and I were able to download and open attachments in v1.8.2 of Good, but once updated to v2.0.0 we cannot. By the way, it's on a Droid Razr.

  • Re: Unable to Download Attachments
    ian.shaffer@otsuka-us.com Newbie

    Many users at my organization are reporting that attachments often take way too long to download through Good no matter what size they are or what file type.  Like small files taking more than 5 minutes before GFE even negotiates the connection (while the attachment just spins saying "Connecting...") and finally begins to download the file.  Once it starts downloading, it goes really fast.  So it is not a bandwidth issue.


    The users that still have Active Synch email enabled go right over to the native iOS email app, and the same attachments come down immediately.  This makes Good look bad and our users frustrated.  Reprovisioning does not help.


    It seems like a Good attachment server issue but I would have expected more users to be experiencing the same problem if this were the case.  Which is why I am posting this question.


    Does anyone else have a similar situation currently?

  • Re: Unable to Download Attachments

    Are there any updates on this? We also have multilple users reporting this issue. Of particular concern is that our execs are being impacted by this and we are trying to wean them away from Blackberry and onto Good but this is not helping our cause.

  • Re: Unable to Download Attachments
    lukesharkey Expert

    I would verify all this is in place as well in these situations. Attachments download over a different port and could be blocked by firewalls at different places using a wifi network.


    Over a Wi-Fi network, the device is initiating a connection to the Good NOC.

    The Wi-Fi access point has to allow the following traffic:


    IP addresses

    Connections allowed to IP range / 27 (Good NOC)

    Connections allowed to IP range / 24 (Good NOC)

    iOS only: Connections allowed to IP range / 8 (Apple Push Notification Service)



    UDP Port 12000 and TCP Port15000: used to pass outbound-initiated traffic to Good once the Good client is installed on the handheld. No need to open inbound-initiated traffic (only inbound “reply” traffic required).

    TCP Port 80 – used to redirect to secure port 443;

    TCP Port 443 – used for secure access to Good Webstore for OTA distribution and download;

    TCP Port 21 – used to FTP logs to Good Technical Support (optional);

    TCP Port 15000 – used for attachment downloading and S/MIME;

    iOS only: TCP Port 5223 – used to receive notifications through Apple Push Notification Service


    UDP Security

    All Connections to Good’s NOC are device-initiated only, but require bidirectional flow. From a security perspective, there are no significant difference between using TCP and UDP for Good Traffic. Good uses a sequenced and encrypted protocol over UDP similar to TCP.


    NAT Time Outs

    To ensure that good can remain up-to-date at all times, Good requires that the NAT time out be set to 9 minutes or longer. This will keep users connected to the network while maximizing the battery life performance on the device.

  • Re: Unable to Download Attachments
    jhenderson Newbie

    anything on this? I am also having this issue.     

  • Re: Unable to Download Attachments

    We were missing the second firewall rule that Luke mentined above and have since implemented this. I have not had any users report the issue since this fix went in a week ago. However, since the issue occured intermittently, I am not sure we can declare victory just yet.

  • Re: Unable to Download Attachments
    lukesharkey Expert

    Attachments are a hit and miss and often the cache is the issue when having problems with them. I usually end up reprovisioning people when this happens. Most folks really don't want to troubleshoot, they just want it to work right away

  • Re: Unable to Download Attachments
    jhenderson Newbie

    My users are now working. I submited a ticket and am told by GOOD that they are researching this issue. If it follows any "researching this issue" history i have had with GOOD, i should have some type of answer in about 2-3 weeks.

  • Re: Unable to Download Attachments
    lukesharkey Expert

    I had a couple that had issues as well. Just started working, no rhyme or reason.

  • Re: Unable to Download Attachments
    sam.hudson Newbie

    Good morning,

         My company is having continued attachment issues as well. The devices just sit on "connecting" for abnormal periods of time before finally downloading the attachment; IF the user is willing to wait. Problem is, users are not willing to wait 2 minutes for the download to actually start, and consider it "hung up" and move on.

    I have a ticket open with Good, but after reviewing device logs they say it is a device connectivity issue. The problem I have with that is that I can run a speed test from the device with the issue and get 14Mbps download speeds and more than half that upload speeds. Additionally, after the device finally gets past the "connecting" portion of downloading the attachment, the actual download is almost instant. This makes me think it has nothing to do with the connection quality, it has something to do with being able to establish the connection with the NOC. Furthermore, it is completely random. As soon as I get 20 or so reports that there are attachment issues and start an investigation, the initial users are not having the issue anymore. Maybe it's a load on the NOC, or like saenz said, something with latency in our data center.

    Still nothing valuable from Good support, so I wanted to check in here and see if anyone has found any concrete cause/solution for this issue?


  • Re: Unable to Download Attachments
    apnetwork.allianz Newbie

    I also experience the same issues with a few of our clients. It appeared for random users at random times. I notice the waiting at "Connecting" seemed to have improved over last update. However there are still cases where it would stay "Connecting" and would never able to start any download. We have tried killing the app and also rebooting the device. We ended up killing the GFE server process, deleting everything in the device cache folders. This way the device can avoid a re-provision, but the entire mailbox needed to reload.

  • Re: Unable to Download Attachments
    bschumacher Newbie

    Has there been any movement on this issue?  I have a user that has this issue over and over again.  I re provision him, and he works fine for a couple of weeks, and then has the same issue again.  He is the only user in our organization that is having this issue.

  • Re: Unable to Download Attachments
    jhenderson Newbie

    i have the same problem. It is an issue with GOOD, they just will not accept it yet.

  • Re: Unable to Download Attachments
    CoopDiddy Novice

    I have had several users with the same issue Android and IOS. Contact the  Good and they stated they would look into it. User has now stated that they can now download attachments. Waiting to hear back from Good if they made any changes on the back end.

  • Re: Unable to Download Attachments
    mg_SBPR Newbie

    Any update on this?